Announcement

Collapse
No announcement yet.

Messed up my filter :(

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Messed up my filter :(

    i really messed up this time... while pouring sand into the 40 i didn't realize the filter was still on... how do i clean it out it made a sputtering noise then shut off... i tried cleaning off the intake and its clear so i don't know why its not working now :/
    2.5g Betta tank (Rayne)
    2.5g Apple Snail tank (Silver)
    1.5g Saltwater MTS vase (tough little dudes)
    40g red ear slider tank (Kappa)
    "Normal is just an illusion. What is normal for the spider is chaos for the fly." -- Morticia Adam

  • #2
    Check the impeller.

    Comment


    • #3
      The impeller is what I was going to say also. Take apart every single piece you can and rinse it really well and cross your fingers and hope it didn't burn out.
      __________________________________________________ __________
      Lori

      30G, 5G

      Comment


      • #4
        I pulled out the impeller and the little fan thing is jammed... not sure how to clear it out I have a small bamboo skewer i am poking at it and its not helping at all :/
        2.5g Betta tank (Rayne)
        2.5g Apple Snail tank (Silver)
        1.5g Saltwater MTS vase (tough little dudes)
        40g red ear slider tank (Kappa)
        "Normal is just an illusion. What is normal for the spider is chaos for the fly." -- Morticia Adam

        Comment


        • #5
          I use a toothpick - usually works. And when you get it going again, put a piece of foam or stocking over your intake so it doesn't suck up any more sand. I have pieces of pantyhose wrapped around my lower intakes.
          __________________________________________________ __________
          Lori

          30G, 5G

          Comment


          • #6
            Ha! fixed it the little fan was jammed by some sludge stuff... also managed to fix the little overflow issue it was having lol
            2.5g Betta tank (Rayne)
            2.5g Apple Snail tank (Silver)
            1.5g Saltwater MTS vase (tough little dudes)
            40g red ear slider tank (Kappa)
            "Normal is just an illusion. What is normal for the spider is chaos for the fly." -- Morticia Adam

            Comment


            • #7
              Isn't it great when something works out right ?
              __________________________________________________ __________
              Lori

              30G, 5G

              Comment


              • #8
                normally... darn this just got stuck again xD at least i know how to pull it apart now!
                2.5g Betta tank (Rayne)
                2.5g Apple Snail tank (Silver)
                1.5g Saltwater MTS vase (tough little dudes)
                40g red ear slider tank (Kappa)
                "Normal is just an illusion. What is normal for the spider is chaos for the fly." -- Morticia Adam

                Comment


                • #9
                  LOL Course you did! I've done that so many times... I would take the entire filter apart and scrub it. Put some Vaseline or StressCoat+ in it. That really helps, especially if it was making noise.
                  -Jonathan

                  Comment


                  • #10
                    Glad you got it fixed! Like Lori suggested, pantyhose works very well. I have it on all my filter intakes.

                    Comment


                    • #11
                      What I always noticed works if something is jammed... I turn on my compressor...put on the air nozzle and ppppppssssssss .... fixes many thing and no technical issues lol
                      It does not matter if you are right or wrong...
                      As long as you learn and Keep Moving Forward!

                      ~Anthony

                      Comment

                      Working...
                      X